Thread: Executor code - found an instance of a WHILE that should just be an IF
Hi, During debugging I noticed some code in ExecResult() where a WHILE loop is being used with an unconditional RETURN at the end of the block (which is intentional, looking at the history of changes), but now there's no actual use of the loop in any way. The code should probably be changed to just use IF for clarity. I've attached a patch. Regards, Greg Nancarrow Fujitsu Australia
Attachment
On Mon, 10 May 2021 at 21:16, Greg Nancarrow <gregn4422@gmail.com> wrote: > During debugging I noticed some code in ExecResult() where a WHILE > loop is being used with an unconditional RETURN at the end of the > block (which is intentional, looking at the history of changes), but > now there's no actual use of the loop in any way. The code should > probably be changed to just use IF for clarity. > I've attached a patch. Looks like leftovers from ea15e1867. I don't think this will affect any code generation but you are right, it should be an "if". David
On Mon, 10 May 2021 at 23:49, David Rowley <dgrowleyml@gmail.com> wrote: > > On Mon, 10 May 2021 at 21:16, Greg Nancarrow <gregn4422@gmail.com> wrote: > > During debugging I noticed some code in ExecResult() where a WHILE > > loop is being used with an unconditional RETURN at the end of the > > block (which is intentional, looking at the history of changes), but > > now there's no actual use of the loop in any way. The code should > > probably be changed to just use IF for clarity. > > I've attached a patch. > > Looks like leftovers from ea15e1867. > > I don't think this will affect any code generation but you are right, > it should be an "if". Since there's no bug fix here, I thought that there's not much point in backpatching this. Does anyone object to making this small change in master? David
Re: Executor code - found an instance of a WHILE that should just be an IF
From
Michael Paquier
Date:
On Thu, May 13, 2021 at 08:20:36PM +1200, David Rowley wrote: > Since there's no bug fix here, I thought that there's not much point > in backpatching this. Indeed. I would not bother with a back-patch either. > Does anyone object to making this small change in master? No objections from here. -- Michael
Attachment
Re: Executor code - found an instance of a WHILE that should just be an IF
From
Julien Rouhaud
Date:
On Thu, May 13, 2021 at 08:06:18PM +0900, Michael Paquier wrote: > On Thu, May 13, 2021 at 08:20:36PM +1200, David Rowley wrote: > > Since there's no bug fix here, I thought that there's not much point > > in backpatching this. > > Indeed. I would not bother with a back-patch either. > > > Does anyone object to making this small change in master? > > No objections from here. +1 to both.
On Fri, 14 May 2021 at 00:27, Julien Rouhaud <rjuju123@gmail.com> wrote: > > On Thu, May 13, 2021 at 08:06:18PM +0900, Michael Paquier wrote: > > On Thu, May 13, 2021 at 08:20:36PM +1200, David Rowley wrote: > > > Since there's no bug fix here, I thought that there's not much point > > > in backpatching this. > > > > Indeed. I would not bother with a back-patch either. > > > > > Does anyone object to making this small change in master? > > > > No objections from here. > > +1 to both. Thanks for the votes. Pushed. David
Re: Executor code - found an instance of a WHILE that should just be an IF
From
Greg Nancarrow
Date:
On Fri, May 14, 2021 at 10:27 AM David Rowley <dgrowleyml@gmail.com> wrote: > > Thanks for the votes. Pushed. Thanks! Regards, Greg Nancarrow Fujitsu Australia