Thread: Command names
I know all of you are accustomed to the command line interface for pgsql. (Of course, some of you created it!) However, I'd be interested if anyone else feels the way I do....
I would prefer to have a consistent set of names for the commands. For example,
I propose the following:
Instead of this use this.
----------------------------------------------------
createdb pg_createdb
createuser pg_createuser
destroydb pg_destroydb
initdb pg_initdb
initlocation pg_initlocation
pgaccess pg_accessgui
pgadmin pg_admin
pg_dump pg_dump
pg_dumpall pg_dumpall
postgres pg_single
postmaster pg_masterpsql pg_access
vacuumdb pg_vacuumdb
??? pg_help (list all these commands)
Not that it is terribly difficult the way it is. But I simply think that a consistent set of names would help new users, and help to prevent conflicts with other commands in the PATH. Any comments?
- Keith
Well, I'm not even a new user, I'm maybe a future new user but interested right now. With the exception of the help command, I don't see any need to change commands names. But the help command would be very helpful. ----- Original Message ----- From: Keith L. Musser To: PGSQL-General Sent: Thursday, September 28, 2000 9:39 AM Subject: [GENERAL] Command names I know all of you are accustomed to the command line interface for pgsql. (Of course, some of you created it!) However, I'd be interested if anyone else feels the way I do.... I would prefer to have a consistent set of names for the commands. For example, I propose the following: Instead of this use this. ---------------------------------------------------- createdb pg_createdb createuser pg_createuser destroydb pg_destroydb initdb pg_initdb initlocation pg_initlocation pgaccess pg_accessgui pgadmin pg_admin pg_dump pg_dump pg_dumpall pg_dumpall postgres pg_single postmaster pg_master psql pg_access vacuumdb pg_vacuumdb ??? pg_help (list all these commands) Not that it is terribly difficult the way it is. But I simply think that a consistent set of names would help new users, and help to prevent conflicts with other commands in the PATH. Any comments? - Keith Keith L. Musser Integrated Dynamics, Inc. 812-371-7777 email: kmusser@idisys.com
I'd assume a problem with changing all the commands now is that it may break a lot of people's scripts and programs. Adam Lang Systems Engineer Rutgers Casualty Insurance Company ----- Original Message ----- From: "Keith L. Musser" <kmusser@idisys.com> To: "PGSQL-General" <pgsql-general@postgresql.org> Sent: Thursday, September 28, 2000 9:39 AM Subject: [GENERAL] Command names I know all of you are accustomed to the command line interface for pgsql. (Of course, some of you created it!) However, I'd be interested if anyone else feels the way I do.... I would prefer to have a consistent set of names for the commands. For example, I propose the following: Instead of this use this. ---------------------------------------------------- createdb pg_createdb createuser pg_createuser destroydb pg_destroydb initdb pg_initdb initlocation pg_initlocation pgaccess pg_accessgui pgadmin pg_admin pg_dump pg_dump pg_dumpall pg_dumpall postgres pg_single postmaster pg_master psql pg_access vacuumdb pg_vacuumdb ??? pg_help (list all these commands) Not that it is terribly difficult the way it is. But I simply think that a consistent set of names would help new users, and help to prevent conflicts with other commands in the PATH. Any comments? - Keith Keith L. Musser Integrated Dynamics, Inc. 812-371-7777 email: kmusser@idisys.com
"Adam Lang" <aalang@rutgersinsurance.com> writes: > I'd assume a problem with changing all the commands now is that it may break > a lot of people's scripts and programs. Well, we've done it before ;-). If memory serves, the create/drop scripts *were* named pg_xxx a few years back. I forget the reasons that were advanced for changing their names, but Keith should go search the archives for that discussion if he wants to pursue the proposal seriously. Adam does have a point though, which is that the Postgres community has grown since then, so there'd be that many more people inconvenienced by a change. I don't think you will get any support for renaming psql; that name is wired into people's fingers, not to mention their scripts. The not-so-commonly-used programs could be renamed without quite so much annoyance, perhaps. BTW, there is a closely related discussion going on right now in pghackers: do we want to make it possible to install the PG programs into a standard directory like /usr/local/bin, and if so doesn't that mean they'd better have less-generic names? regards, tom lane
It would probably be easy to create a link, or a script called pg_XXX that executes the command XXX. I'd rather have createdb instead of pg_createdb just because it's easier to type. A script that creates the pg_ command names could be written and made available at someone's web site for people who wanted it. ---------------------------------------------------------------- Travis Bauer | CS Grad Student | IU |www.cs.indiana.edu/~trbauer ---------------------------------------------------------------- On Thu, 28 Sep 2000, Keith L. Musser wrote: > I know all of you are accustomed to the command line interface for pgsql. (Of course, some of you created it!) However,I'd be interested if anyone else feels the way I do.... > > I would prefer to have a consistent set of names for the commands. For example, > I propose the following: > > Instead of this use this. > ---------------------------------------------------- > createdb pg_createdb > createuser pg_createuser > destroydb pg_destroydb > initdb pg_initdb > initlocation pg_initlocation > pgaccess pg_accessgui > pgadmin pg_admin > pg_dump pg_dump > pg_dumpall pg_dumpall > postgres pg_single > postmaster pg_master > psql pg_access > vacuumdb pg_vacuumdb > ??? pg_help (list all these commands) > > > Not that it is terribly difficult the way it is. But I simply think that a consistent set of names would help new users,and help to prevent conflicts with other commands in the PATH. Any comments? > > - Keith > > Keith L. Musser > Integrated Dynamics, Inc. > 812-371-7777 > email: kmusser@idisys.com > >
I was about to say that it may cause more harm than good, but... If they do want to move the utilities to the /bin folder, then that may be a good solution. pg_access, pg_createdb etc would be put there and merely mapped to the usual location of the createdb utilities. That would solve the issues, correct? Adam Lang Systems Engineer Rutgers Casualty Insurance Company ----- Original Message ----- From: "Travis Bauer" <trbauer@cs.indiana.edu> To: "Keith L. Musser" <kmusser@idisys.com> Cc: "PGSQL-General" <pgsql-general@postgresql.org> Sent: Thursday, September 28, 2000 12:28 PM Subject: Re: [GENERAL] Command names > > > It would probably be easy to create a link, or a script called pg_XXX that > executes the command XXX. I'd rather have createdb instead of pg_createdb > just because it's easier to type. A script that creates the pg_ command > names could be written and made available at someone's web site for people > who wanted it. > > > ---------------------------------------------------------------- > Travis Bauer | CS Grad Student | IU |www.cs.indiana.edu/~trbauer > ---------------------------------------------------------------- > > On Thu, 28 Sep 2000, Keith L. Musser wrote: > > > I know all of you are accustomed to the command line interface for pgsql. (Of course, some of you created it!) However, I'd be interested if anyone else feels the way I do.... > > > > I would prefer to have a consistent set of names for the commands. For example, > > I propose the following: > > > > Instead of this use this. > > ---------------------------------------------------- > > createdb pg_createdb > > createuser pg_createuser > > destroydb pg_destroydb > > initdb pg_initdb > > initlocation pg_initlocation > > pgaccess pg_accessgui > > pgadmin pg_admin > > pg_dump pg_dump > > pg_dumpall pg_dumpall > > postgres pg_single > > postmaster pg_master > > psql pg_access > > vacuumdb pg_vacuumdb > > ??? pg_help (list all these commands) > > > > > > Not that it is terribly difficult the way it is. But I simply think that a consistent set of names would help new users, and help to prevent conflicts with other commands in the PATH. Any comments? > > > > - Keith > > > > Keith L. Musser > > Integrated Dynamics, Inc. > > 812-371-7777 > > email: kmusser@idisys.com > > > >