Re: New "single-call SRF" APIs are very confusingly named - Mailing list pgsql-hackers

From Melanie Plageman
Subject Re: New "single-call SRF" APIs are very confusingly named
Date
Msg-id CAAKRu_b+1c=2JZo0vNR7UBOCYegt8V7HeNGoiQ6TfyQunKOexQ@mail.gmail.com
Whole thread Raw
In response to Re: New "single-call SRF" APIs are very confusingly named  (Michael Paquier <michael@paquier.xyz>)
Responses Re: New "single-call SRF" APIs are very confusingly named  (Andres Freund <andres@anarazel.de>)
List pgsql-hackers

On Fri, Oct 14, 2022 at 7:41 PM Michael Paquier <michael@paquier.xyz> wrote:
On Fri, Oct 14, 2022 at 05:09:46PM -0400, Melanie Plageman wrote:
> To summarize, I am in support of renaming SetSingleFuncCall() ->
> InitMaterializedSRF() and SRF_SINGLE_USE_EXPECTED ->
> MAT_SRF_USE_EXPECTED_TUPLE_DESC (or just DESC) as suggested elsewhere in
> this thread. And I think we should eventually consider renaming the
> multi* function names and consider if ExprSingleResult is a good name.

As already mentioned, these have been around for years, so the impact
would be bigger. 

That makes sense.
 
Attached is a patch for HEAD and REL_15_STABLE to
switch this stuff with new names, with what's needed for ABI
compatibility.  My plan would be to keep the compatibility parts only
in 15, and drop them from HEAD.

- * SetSingleFuncCall
+ * Compatibility function for v15.
+ */
+void
+SetSingleFuncCall(FunctionCallInfo fcinfo, bits32 flags)
+{
+ InitMaterializedSRF(fcinfo, flags);
+}
+

 Any reason not to use a macro?

- Melanie

pgsql-hackers by date:

Previous
From: Matthias van de Meent
Date:
Subject: Re: PATCH: Using BRIN indexes for sorted output
Next
From: Tom Lane
Date:
Subject: Re: macos ventura SDK spews warnings