Thread: [dsm] comment typo
In the following sentence, I believe either 'the' or 'a' should be kept, not both. I here keep the 'the', but feel free to change. --- src/backend/storage/ipc/dsm_impl.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/backend/storage/ipc/dsm_impl.c b/src/backend/storage/ipc/dsm_impl.c index 6399fa2ad5..19a9cfc8ac 100644 --- a/src/backend/storage/ipc/dsm_impl.c +++ b/src/backend/storage/ipc/dsm_impl.c @@ -137,7 +137,7 @@ int min_dynamic_shared_memory; * Arguments: * op: The operation to be performed. * handle: The handle of an existing object, or for DSM_OP_CREATE, the - * a new handle the caller wants created. + * new handle the caller wants created. * request_size: For DSM_OP_CREATE, the requested size. Otherwise, 0. * impl_private: Private, implementation-specific data. Will be a pointer * to NULL for the first operation on a shared memory segment within this -- -- Regards Junwang Zhao
> On 18 Aug 2023, at 11:10, Junwang Zhao <zhjwpku@gmail.com> wrote: > > In the following sentence, I believe either 'the' or 'a' should be kept, not > both. I here keep the 'the', but feel free to change. > * handle: The handle of an existing object, or for DSM_OP_CREATE, the > - * a new handle the caller wants created. > + * new handle the caller wants created. Since the handle doesn't exist for DSM_OP_CREATE, both "a handle" and "the handle" seems a tad misleading, how about "the identifier for the new handle the caller wants created"? -- Daniel Gustafsson
On Mon, Aug 21, 2023 at 5:16 PM Daniel Gustafsson <daniel@yesql.se> wrote: > > > On 18 Aug 2023, at 11:10, Junwang Zhao <zhjwpku@gmail.com> wrote: > > > > In the following sentence, I believe either 'the' or 'a' should be kept, not > > both. I here keep the 'the', but feel free to change. > > > * handle: The handle of an existing object, or for DSM_OP_CREATE, the > > - * a new handle the caller wants created. > > + * new handle the caller wants created. > > Since the handle doesn't exist for DSM_OP_CREATE, both "a handle" and "the > handle" seems a tad misleading, how about "the identifier for the new handle the > caller wants created"? > Sounds great 👍 > -- > Daniel Gustafsson > -- Regards Junwang Zhao
> On 21 Aug 2023, at 12:15, Junwang Zhao <zhjwpku@gmail.com> wrote: > > On Mon, Aug 21, 2023 at 5:16 PM Daniel Gustafsson <daniel@yesql.se> wrote: >> >>> On 18 Aug 2023, at 11:10, Junwang Zhao <zhjwpku@gmail.com> wrote: >>> >>> In the following sentence, I believe either 'the' or 'a' should be kept, not >>> both. I here keep the 'the', but feel free to change. >> >>> * handle: The handle of an existing object, or for DSM_OP_CREATE, the >>> - * a new handle the caller wants created. >>> + * new handle the caller wants created. >> >> Since the handle doesn't exist for DSM_OP_CREATE, both "a handle" and "the >> handle" seems a tad misleading, how about "the identifier for the new handle the >> caller wants created"? >> > > Sounds great Done that way, thanks! -- Daniel Gustafsson