Peter Eisentraut <peter.eisentraut@enterprisedb.com> writes:
> I was wondering why we have a definition of Abs() in c.h when there are
> more standard functions such as abs() and fabs() in widespread use. I
> think this one is left over from pre-ANSI-C days. The attached patches
> replace all uses of Abs() with more standard functions.
I'm not in favor of the llabs() changes. I think what we really want
in those places, or at least most of them, is "abs() for int64".
That could be had by #define'ing "iabs64" (or some name along that
line) as labs or llabs depending on which type we are using for int64.
Seems OK beyond that nitpick.
regards, tom lane