On Thu, Apr 10, 2025 at 10:12:34AM +0300, Maksim.Melnikov wrote:
> but I am afraid we are loosing this.
>
> if (WalSndCtl->sync_standbys_status & SYNC_STANDBY_INIT)
> {
> if ((WalSndCtl->sync_standbys_status & SYNC_STANDBY_DEFINED) == 0 ||
> lsn <= WalSndCtl->lsn[mode])
> {
> LWLockRelease(SyncRepLock);
> return;
> }
> }
> [...]
> + else if (lsn <= WalSndCtl->lsn[mode])
> + {
> + LWLockRelease(SyncRepLock);
> + return;
> + }
>
> What do you think?
Hmm, yeah. Instead of last, it would be better to put it in second
place perhaps, for clarity? That would be the same at the end, but we
would be slightly more consistent with the past logic regarding the
ordering. Does that look OK to you?
--
Michael