> The current CVS sources look wrong to me. It has:
>
> if (result != null) && ((org.postgresql.ResultSet)result.reallyResultSet())
>
> Shouldn't this be:
>
> if (result != null && ((org.postgresql.ResultSet)result.reallyResultSet()))
>
> Not sure if the extra parens are needed for:
>
> if (result != null && ((org.postgresql.ResultSet)result).reallyResultSet())
>
> Comments?
The extra parenthesis are required (since java.sql.ResultSet doesn't
have a method 'reallyResultSet()' which returns an object which can be
succesfully cast as a 'org.postgresql.ResultSet), but I think it would be
cleaner just to declare 'result' as 'org.postgresql.ResultSet' on line 27,
that way none of the messy casts (of which there are 11) would be
required..
Michael xxx