Re: PG_GETARG_GISTENTRY? - Mailing list pgsql-hackers

From Mark Dilger
Subject Re: PG_GETARG_GISTENTRY?
Date
Msg-id EA5676F4-766F-4F38-8348-ECC7DB427C6A@gmail.com
Whole thread Raw
In response to Re: PG_GETARG_GISTENTRY?  (Tom Lane <tgl@sss.pgh.pa.us>)
Responses Re: PG_GETARG_GISTENTRY?  (Tom Lane <tgl@sss.pgh.pa.us>)
List pgsql-hackers
> On Apr 5, 2017, at 9:23 AM, Tom Lane <tgl@sss.pgh.pa.us> wrote:
>
> Robert Haas <robertmhaas@gmail.com> writes:
>> On Wed, Mar 29, 2017 at 11:54 PM, Tom Lane <tgl@sss.pgh.pa.us> wrote:
>>> Andres Freund <andres@anarazel.de> writes:
>>>> we have a good number of '(GISTENTRY *) PG_GETARG_POINTER(n)' in our
>>>> code - looks a bit better & shorter to have PG_GETARG_GISTENTRY(n).
>
>>> Should be PG_GETARG_GISTENTRY_P to match existing conventions,
>>> otherwise +1
>
>> I have never quite understood why some of those macros have _P or _PP
>> on the end and others don't.
>
> _P means "pointer to".  _PP was introduced later to mean "pointer to
> packed (ie, possibly short-header) datum".  Macros that mean to fetch
> pointers to pass-by-ref data, but aren't using either of those naming
> conventions, are violating project conventions, not least because you
> don't know what they're supposed to do with short-header varlena input.
> If I had a bit more spare time I'd run around and change any such macros.
>
> In short, if you are supposed to write
>
>     FOO  *val = PG_GETARG_FOO(n);
>
> then the macro designer blew it, because the name implies that it
> returns FOO, not pointer to FOO.  This should be
>
>     FOO  *val = PG_GETARG_FOO_P(n);
>
>             regards, tom lane

I have written a patch to fix these macro definitions across src/ and contrib/.
Find the patch, attached.  All regression tests pass on my Mac laptop.

I don't find any inappropriate uses of _P where _PP would be called for.  I do,
however, notice that some datatypes' functions are written to use PG_GETARG_*_P
where PG_GETARG_*_PP might be more efficient.  Varbit's bitoctetlength function
could detoast only the header ala PG_DETOAST_DATUM_SLICE to return the
octet length, rather than detoasting the whole thing.  But that seems a different
issue, and patches to change that might have been rejected in the past so far as I
know, so I did not attempt any such changes here.

Mark Dilger





Attachment

pgsql-hackers by date:

Previous
From: Simon Riggs
Date:
Subject: Re: increasing the default WAL segment size
Next
From: Tom Lane
Date:
Subject: Re: PG_GETARG_GISTENTRY?