Re: Propose a new function - list_is_empty - Mailing list pgsql-hackers

From Peter Smith
Subject Re: Propose a new function - list_is_empty
Date
Msg-id CAHut+PsZTZXOjymooviD99jEdw6BYxYdD29Yg3C=VuUkOx1EtQ@mail.gmail.com
Whole thread Raw
In response to Re: Propose a new function - list_is_empty  (Tom Lane <tgl@sss.pgh.pa.us>)
List pgsql-hackers
On Tue, Aug 16, 2022 at 11:27 AM Tom Lane <tgl@sss.pgh.pa.us> wrote:
>
> Peter Smith <smithpb2250@gmail.com> writes:
> > During a recent code review I was going to suggest that some new code
> > would be more readable if the following:
> > if (list_length(alist) == 0) ...
>
> > was replaced with:
> > if (list_is_empty(alist)) ...
>
> > but then I found that actually no such function exists.
>
> That's because the *correct* way to write it is either "alist == NIL"
> or just "!alist".  I don't think we need yet another way to spell
> that, and I'm entirely not on board with replacing either of those
> idioms.  But if you want to get rid of overcomplicated uses of
> list_length() in favor of one of those spellings, have at it.
>

Thanks for your advice.

Yes, I saw that NIL is the definition of an empty list - that's how I
implemented list_is_empty.

OK, I'll ditch the function idea and just look at de-complicating
those existing empty List checks.

------
Kind Regards,
Peter Smith.
Fujitsu Australia



pgsql-hackers by date:

Previous
From: Tom Lane
Date:
Subject: Re: Propose a new function - list_is_empty
Next
From: John Naylor
Date:
Subject: Re: fix typos