As part of the WAL-format changing patch I've been working on, I changed
the signature of the rm_desc function from:
void (*rm_desc) (StringInfo buf, uint8 xl_info, char *rec);
void (*rm_desc) (StringInfo buf, XLogRecord *record);
The WAL-format patch needed that because it added more functions/macros
for working with XLogRecords, also used by rm_desc routines, but it
seems like a sensible change anyway. IMHO it was always a bit strange
that rm_desc was passed the info field and record payload separately.
So I propose to do that change as a separate commit. Per attached. This
has no functional changes, it's just refactoring.
Any objections?
- Heikki