> > "P" for "Parser".
> Oh, okay. I'm not intent on changing it, just was wondering what the
> motivation was. What do you think of changing all the token symbols to
> be FOO_P? (Or P_FOO, per your comment, but I'd just as soon leave alone
> the ones that already have a suffix.)
No problem here. I have a mild preference for suffix notation, and the
"P_FOO" was *your* idea (or at least the "DTF_FOO" one was). Anyway,
suffixes are my preference, but not I'm not enthused enough about it to
argue hard one way or the other.
> > The symbols are used past the lexer, but are isolated
> > to other places in the parser, and are (or should be) stripped out
> > beyond there.
> Right at the moment we have half a dozen cases where they leak past the
> parser, e.g. TransactionStmt. I've been intending to clean that up.
> I concur that we don't want anything past parse analysis to depend on
> token values, since they change anytime the keyword set changes.
Right.
> > If the lexer/parser should have postfix qualifiers, let's use postfix
> > for other naming conventions too (or switch everything to prefix, but be
> > consistant in the conventions).
> I'd settle for local consistency: if we need prefixes/suffixes on some
> of the datetime field names, let's make all of them have one. But I
> don't feel compelled to cause a flag day over the whole source tree ;-).
> At least not all at once.
Well, this doesn't need to be an issue or argument. We have little or no
precedent for prefix notation that I can recall, we have postfix
notation in the parser, and we don't have a "namespace convention" for
other areas afaik. So if we make changes, let's do it with a convention,
and at least extend one local convention to another local area.
Question to all: Any objection to postfix? If so, why?
And to answer Katherine's original questions:
1) OK. (function renaming)
2) OK. ("_P" suffix on a few more parser tokens)
3) MEM_FREE_IT - OK, but is it a macro specific to something in dynhash?
If so, how about using something more specific than "it"?
IGNORE_TOK - How about "IGNORE_DTF" or "IGNORE_D"? Let's make it a bit
specific to date/time stuff.
- Thomas