Thread: use_remote_explain missing in docs of postgres_fdw
Hi all,<br /><br />While testing a bit this feature, I noticed that use_remote_explain is available in the list of optionsfor FOREIGN TABLE and SERVER but this is not specified in the docs:<br /><a href="http://www.postgresql.org/docs/devel/static/postgres-fdw.html" target="_blank">http://www.postgresql.org/docs/devel/static/postgres-fdw.html</a><br/><br />postgres=# CREATE FOREIGN TABLEfoo (a int, b int) server postgres_server options (table_name 'aa', foo 'true');<br />ERROR: invalid option "foo"<br/> HINT: Valid options in this context are: schema_name, table_name, use_remote_explain<br /><br />Regards,<br />--<br />Michael<br />
Michael Paquier <michael.paquier@gmail.com> writes: > While testing a bit this feature, I noticed that use_remote_explain is > available in the list of options for FOREIGN TABLE and SERVER but this is > not specified in the docs: > http://www.postgresql.org/docs/devel/static/postgres-fdw.html Wups ... for some reason it's "use_remote_estimate" in the docs. Thinko on my part probably --- although on reflection, maybe that's a better name anyway? regards, tom lane
On Fri, Feb 22, 2013 at 5:13 PM, Tom Lane <tgl@sss.pgh.pa.us> wrote:
-- Michael Paquier <michael.paquier@gmail.com> writes:Wups ... for some reason it's "use_remote_estimate" in the docs. Thinko
> While testing a bit this feature, I noticed that use_remote_explain is
> available in the list of options for FOREIGN TABLE and SERVER but this is
> not specified in the docs:
> http://www.postgresql.org/docs/devel/static/postgres-fdw.html
on my part probably --- although on reflection, maybe that's a better
name anyway?
Indeed, use_remote_estimate is better. use_remote_explain makes it sound like an EXPLAIN query would be sent to remote server. That is at least the first impression I had when testing the feature without reading the docs.
Michael
Michael Paquier <michael.paquier@gmail.com> writes: > On Fri, Feb 22, 2013 at 5:13 PM, Tom Lane <tgl@sss.pgh.pa.us> wrote: >> Wups ... for some reason it's "use_remote_estimate" in the docs. Thinko >> on my part probably --- although on reflection, maybe that's a better >> name anyway? > Indeed, use_remote_estimate is better. use_remote_explain makes it sound > like an EXPLAIN query would be sent to remote server. That is at least the > first impression I had when testing the feature without reading the docs. Well, it does do that, at least for the part of the query that will be executed on the remote server. But if you read it to mean the whole query would be EXPLAINed on the remote server, that's wrong. The objection I have to "use_remote_explain" is that it's focusing too much on the mechanism (ie, send an EXPLAIN command for execution) rather than the result (ie, get a cost estimate from the remote server). So I'm inclined to change the code to match the docs rather than vice versa. Anyone have a contrary opinion? regards, tom lane