Hello Hackers!
Andrey, thank you for your review and remarks.
> Patch adds whitespace errors
Cleaned.
> if (writePage != 0) should be if (writePage)
Done.
> XLogSimpleInsert(int64 simpledata, RmgrId rmid, uint8 info)
> I’d rename function XLogSimpleInsert() to something more descriptive
> and changed arguments order from generic to specific.
The function has been renamed and the parameters have been reordered.
Now we have:
XLogInsertInt64(RmgrId rmid, uint8 info, int64 simpledata)
> Probably, committer has broader view on XLog routines and can decide
> if this function would better belong to SLRU than common XLog stuff.
In accordance with Álvaro's proposal, we want to enclose this function
in the "xloginsert.c" module.
Best regards,
Evgeny Voropaev.