Re: Michael Paquier
> This is OK on its own, still feels a bit incomplete, as the relid also
> includes an assumption about the namespace. I would suggested to add
> a hardcoded "pg_temp" here, to keep track of this assumption, at
> least.
I had thought about it, but figured that integers and strings are
already separate namespaces, so hashing them shouldn't have any
conflicts. But it's more clear to do that, so added in the new
version:
AppendJumble(jstate, (const unsigned char *)"pg_temp", sizeof("pg_temp"));
AppendJumble(jstate, (const unsigned char *)rel_name, strlen(rel_name));
> typedef struct RangeTblEntry
> {
> - pg_node_attr(custom_read_write)
> + pg_node_attr(custom_read_write, custom_query_jumble)
>
> This structure still includes some query_jumble_ignore, which are not
> required once custom_query_jumble is added.
I would tend to keep them for documentation purposes. (The other
custom_query_jumble functions have a much more explicit structure so
there it is clear which fields are supposed to be jumbled.)
> We had better document at the top of RangeTblEntry why we are using a
> custom function.
I added a short comment just above custom_query_jumble.
Christoph