Bill Studenmund writes:
> I've attached a patch to add the CREATE OPERATOR CLASS we talked about on
> -hackers.
I'm having a few issues with the syntax. Basically, what you have is
CREATE OPERATOR CLASS name FOR TYPE type AS ... USING ... WITH ... AND ...
How about choosing these key words so that they actually declare what the
... stands for. It would also nice if these could be allowed in a more
flexible order.
For instance,
CREATE OPERATOR CLASS name FOR TYPE type
{ STORAGE name
| ACCESS METHOD name
| FUNCTION num name(x, y, z)
| OPERATOR num name
} [, ...]
or
CREATE OPERATOR CLASS name FOR TYPE type
{
STORAGE name
| ACCESS METHOD name } [, ...]
| FUNCTION (
num name(x, y, z),
...
)
| OPERATOR (
num name,
...
)
}
--
Peter Eisentraut peter_e@gmx.net