Was there some change in functionality reason for renaming is_array_type
to type_is_array? It broke compilation of fulldisjunctions, which I build
and run regression tests on in my sandbox to keep it getting too horribly
broken with respect to current HEAD. I got it to build and pass its
regression tests by adding this:
+ #if !defined(is_array_type) && defined(type_is_array)
+ #define is_array_type(x) type_is_array(x)
+ #endif
to the beginning of the one file which uses is_array_type. Is this
reasonable to send back to the fulldisjunctions maintainer, or is there
some subtle change that prompted the name change to make uses of this
function immediately apparent?
--
Ducharme's Axiom:If you view your problem closely enough you will recognizeyourself as part of the problem.