Rename alloc/free functions in reorderbuffer.c
There used to be bespoken pools for these structs to reduce the
palloc/pfree overhead, but that was ripped out a long time ago and
replaced with the generic, cheaper generational memory allocator
(commit a4ccc1cef5). The Get/Return terminology made sense with the
pools, as you "got" an object from the pool and "returned" it later,
but now it just looks weird. Rename to Alloc/Free.
Reviewed-by: Tom Lane <tgl@sss.pgh.pa.us>
Discussion: https://www.postgresql.org/message-id/c9e43d2d-8e83-444f-b111-430377368989@iki.fi
Branch
------
master
Details
-------
https://git.postgresql.org/pg/commitdiff/ac4494646daee27df20f7cded3ad49be24e9a98c
Modified Files
--------------
src/backend/replication/logical/decode.c | 26 ++++----
src/backend/replication/logical/reorderbuffer.c | 89 ++++++++++++-------------
src/include/replication/reorderbuffer.h | 15 ++---
3 files changed, 64 insertions(+), 66 deletions(-)