Rename some shared memory initialization routines
To make them follow the usual naming convention where
FoobarShmemSize() calculates the amount of shared memory needed by
Foobar subsystem, and FoobarShmemInit() performs the initialization.
I didn't rename CreateLWLocks() and InitShmmeIndex(), because they are
a little special. They need to be called before any of the other
ShmemInit() functions, because they set up the shared memory
bookkeeping itself. I also didn't rename InitProcGlobal(), because
unlike other Shmeminit functions, it's not called by individual
backends.
Reviewed-by: Andreas Karlsson
Discussion: https://www.postgresql.org/message-id/c09694ff-2453-47e5-b26c-32a16cd75ce6@iki.fi
Branch
------
master
Details
-------
https://git.postgresql.org/pg/commitdiff/478846e7688c9ab73d2695a66822e9ae0574b551
Modified Files
--------------
src/backend/storage/buffer/buf_init.c | 6 +++---
src/backend/storage/buffer/bufmgr.c | 2 +-
src/backend/storage/buffer/freelist.c | 2 +-
src/backend/storage/ipc/ipci.c | 14 +++++++-------
src/backend/storage/ipc/procarray.c | 4 ++--
src/backend/storage/ipc/sinvaladt.c | 10 +++++-----
src/backend/storage/lmgr/predicate.c | 6 +++---
src/backend/utils/activity/backend_status.c | 4 ++--
src/backend/utils/init/postinit.c | 2 +-
src/include/storage/bufmgr.h | 6 +++---
src/include/storage/predicate.h | 2 +-
src/include/storage/procarray.h | 2 +-
src/include/storage/sinvaladt.h | 4 ++--
src/include/utils/backend_status.h | 2 +-
14 files changed, 33 insertions(+), 33 deletions(-)