pgsql: Rename some variables related to ident files in hba.{c,h} - Mailing list pgsql-committers

From Michael Paquier
Subject pgsql: Rename some variables related to ident files in hba.{c,h}
Date
Msg-id E1pFq4T-003Ebl-9P@gemulon.postgresql.org
Whole thread Raw
List pgsql-committers
Rename some variables related to ident files in hba.{c,h}

The code that handles authentication for user maps was pretty confusing
with its choice of variable names.  It involves two types of users: a
system user and a Postgres user (well, role), and these were not named
consistently throughout the code that processes the user maps loaded
from pg_ident.conf at authentication.

This commit changes the following things to improve the situation:
- Rename "pg_role" to "pg_user" and "token" to "system_user" in
IndetLine.  These choices are more consistent with the pg_ident.conf
example in the docs, as well.  "token" has been introduced recently in
fc579e1, and it is way worse than the choice before that, "ident_user".
- Switch the order of the fields in IdentLine to map with the order of
the items in the ident files, as of map name, system user and PG user.
- In check_ident_usermap(), rename "regexp_pgrole" to "expanded_pg_user"
when processing a regexp for the system user entry in a user map.  This
variable does not store a regular expression at all: it would be either
a string or a substitution to \1 if the Postgres role is specified as
such.

Author: Jelte Fennema
Discussion: https://postgr.es/m/CAGECzQTkwELHUOAKhvdA+m3tWbUQySHHkExJV8GAZ1pwgbEgXg@mail.gmail.com

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/8607630d74cd83f636a72eb9f2eb62f67e1fb955

Modified Files
--------------
src/backend/libpq/hba.c          | 78 ++++++++++++++++++++--------------------
src/backend/utils/adt/hbafuncs.c |  4 +--
src/include/libpq/hba.h          |  6 ++--
3 files changed, 44 insertions(+), 44 deletions(-)


pgsql-committers by date:

Previous
From: Michael Paquier
Date:
Subject: pgsql: Fix incorrect comment in hba.h
Next
From: Michael Paquier
Date:
Subject: Re: pgsql: Revert "Get rid of the "new" and "old" entries in a view's range