pgsql: Rename debug_invalidate_system_caches_always to debug_discard_ca - Mailing list pgsql-committers

From Tom Lane
Subject pgsql: Rename debug_invalidate_system_caches_always to debug_discard_ca
Date
Msg-id E1m3Neb-0005la-Na@gemulon.postgresql.org
Whole thread Raw
List pgsql-committers
Rename debug_invalidate_system_caches_always to debug_discard_caches.

The name introduced by commit 4656e3d66 was agreed to be unreasonably
long.  To match this change, rename initdb's recently-added
--clobber-cache option to --discard-caches.

Discussion: https://postgr.es/m/1374320.1625430433@sss.pgh.pa.us

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/d68a00391214be2020e49be4b55f761d47a5c229

Modified Files
--------------
contrib/postgres_fdw/expected/postgres_fdw.out  |  6 +++---
contrib/postgres_fdw/sql/postgres_fdw.sql       |  6 +++---
doc/src/sgml/config.sgml                        |  8 ++++----
doc/src/sgml/ref/initdb.sgml                    | 22 ++++++++++-----------
doc/src/sgml/regress.sgml                       |  2 +-
src/backend/utils/adt/lockfuncs.c               |  8 ++++----
src/backend/utils/cache/inval.c                 | 16 +++++++--------
src/backend/utils/cache/plancache.c             |  5 ++---
src/backend/utils/cache/relcache.c              | 17 ++++++++--------
src/backend/utils/misc/guc.c                    | 12 ++++++------
src/bin/initdb/initdb.c                         |  6 +++---
src/include/pg_config_manual.h                  | 26 ++++++++++++-------------
src/include/utils/inval.h                       |  2 +-
src/pl/plpgsql/src/expected/plpgsql_cache.out   | 12 ++++++------
src/pl/plpgsql/src/expected/plpgsql_cache_1.out | 12 ++++++------
src/pl/plpgsql/src/expected/plpgsql_record.out  |  8 ++++----
src/pl/plpgsql/src/sql/plpgsql_cache.sql        | 12 ++++++------
src/pl/plpgsql/src/sql/plpgsql_record.sql       |  8 ++++----
src/test/isolation/specs/deadlock-soft-2.spec   |  2 +-
19 files changed, 94 insertions(+), 96 deletions(-)


pgsql-committers by date:

Previous
From: Tom Lane
Date:
Subject: Re: pgsql: Add PSQL_WATCH_PAGER for psql's \watch command.
Next
From: David Rowley
Date:
Subject: pgsql: Change the name of the Result Cache node to Memoize