pgsql: Rename VACOPT_NOWAIT to VACOPT_SKIP_LOCKED - Mailing list pgsql-committers

From Michael Paquier
Subject pgsql: Rename VACOPT_NOWAIT to VACOPT_SKIP_LOCKED
Date
Msg-id E1fdUAb-0002WU-WE@gemulon.postgresql.org
Whole thread Raw
List pgsql-committers
Rename VACOPT_NOWAIT to VACOPT_SKIP_LOCKED

When it comes to SELECT ... FOR or LOCK, NOWAIT means to not wait for
something to happen, and issue an error.  SKIP LOCKED means to not wait
for something to happen but to move on without issuing an error.  The
internal option of autovacuum and autoanalyze mentioned above, used only
when wraparound is not involved was named NOWAIT, but behaves like SKIP
LOCKED which is confusing.

Author: Nathan Bossart
Discussion: https://postgr.es/m/20180307050345.GA3095@paquier.xyz

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/edc6b41bd4a80ea6aebacbd86ebe7c3a01939789

Modified Files
--------------
src/backend/commands/analyze.c      | 2 +-
src/backend/commands/vacuum.c       | 2 +-
src/backend/postmaster/autovacuum.c | 2 +-
src/include/nodes/parsenodes.h      | 3 ++-
4 files changed, 5 insertions(+), 4 deletions(-)


pgsql-committers by date:

Previous
From: Michael Paquier
Date:
Subject: pgsql: Add assertion in expand_vacuum_rel() for non-autovacuum path
Next
From: Amit Kapila
Date:
Subject: pgsql: Allow using the updated tuple while moving it to a differentpar