Hi Nisha,
Here are my review comments for the v53* patch set
//////////
Patch v53-0001.
======
src/backend/replication/slot.c
1.
+ if (error_if_invalid &&
+ s->data.invalidated != RS_INVAL_NONE)
Looks like some unnecessary wrapping here. I think this condition can
be on one line.
//////////
Patch v53-0002.
======
GENERAL - How about using the term "idle"?
1.
I got to wondering why this new GUC was called
"replication_slot_inactive_timeout", with invalidation_reason =
"inactive_timeout". When I look at similar GUCs I don't see words like
"inactivity" or "inactive" anywhere; Instead, they are using the term
"idle" to refer to when something is inactive:
e.g.
#idle_in_transaction_session_timeout = 0 # in milliseconds, 0 is disabled
#idle_session_timeout = 0 # in milliseconds, 0 is disabled
I know the "inactive" term is used a bit in the slot code but that is
(mostly) not exposed to the user. Therefore, I am beginning to feel it
would be better (e.g. more consistent) to use "idle" for the
user-facing stuff. e.g.
New Slot GUC = "idle_replication_slot_timeout"
Slot invalidation_reason = "idle_timeout"
Of course, changing this will cascade to impact quite a lot of other
things in the patch -- comments, error messages, some function names
etc.
======
doc/src/sgml/logical-replication.sgml
2.
+ <para>
+ Logical replication slot is also affected by
+ <link
linkend="guc-replication-slot-inactive-timeout"><varname>replication_slot_inactive_timeout</varname></link>.
+ </para>
+
/Logical replication slot is also affected by/Logical replication
slots are also affected by/
======
Kind Regards,
Peter Smith.
Fujitsu Australia