On Tue, Aug 16, 2022 at 11:27 AM Tom Lane <tgl@sss.pgh.pa.us> wrote:
>
> Peter Smith <smithpb2250@gmail.com> writes:
> > During a recent code review I was going to suggest that some new code
> > would be more readable if the following:
> > if (list_length(alist) == 0) ...
>
> > was replaced with:
> > if (list_is_empty(alist)) ...
>
> > but then I found that actually no such function exists.
>
> That's because the *correct* way to write it is either "alist == NIL"
> or just "!alist". I don't think we need yet another way to spell
> that, and I'm entirely not on board with replacing either of those
> idioms. But if you want to get rid of overcomplicated uses of
> list_length() in favor of one of those spellings, have at it.
Done, and tested OK with make check-world.
PSA.
------
Kind Regards,
Peter Smith.
Fujitsu Australia.