Re: Use "protocol options" name instead of "protocol extensions" everywhere - Mailing list pgsql-hackers

From Jelte Fennema-Nio
Subject Re: Use "protocol options" name instead of "protocol extensions" everywhere
Date
Msg-id CAGECzQS0-2sNcDNuUGxiaKg_SGc5Ow9OPTPkTUQdyDB3_iKp9Q@mail.gmail.com
Whole thread Raw
In response to Re: Use "protocol options" name instead of "protocol extensions" everywhere  (Heikki Linnakangas <hlinnaka@iki.fi>)
List pgsql-hackers
On Thu, 31 Oct 2024 at 15:50, Heikki Linnakangas <hlinnaka@iki.fi> wrote:
> Bikeshedding time:

Another few options:
4. Protocol enhancement
5. Protocol flag
6. Protocol feature-flag
7. Protocol configuration
8. Protocol parameter

One thing to consider is that there's two ways of using them:
1. Turning an optional protocol feature on/of (send LSN yes/no)
2. Configuring an optional protocol feature (compress with gzip/lz4/zstd)

I think "protocol extension" is a good name for the first. But it
reads/writes a bit awkward for the second usage imo:.
1. The wait_for_lsn protocol extension needs to be enabled.
2. I configured the compression protocol extension to be gzip.

I like that "protocol option" because it works for both:
1. The wait_for_lsn protocol option needs to be enabled.
2. I set the compression protocol option to gzip.

I still think of these "protocol xyzs" as essentially being GUCs for
the protocol. Especially because they are configured the same way as
GUCs in the StartupMessage. So having "protocol option" making you
think of GUCs doesn't necessarily seem like a bad thing to me.



pgsql-hackers by date:

Previous
From: Jacob Champion
Date:
Subject: Re: Use "protocol options" name instead of "protocol extensions" everywhere
Next
From: Aleksander Alekseev
Date:
Subject: Re: "command cannot affect row a second time" in INSERT ... ON CONFLICT