On Wed, Nov 10, 2021 at 1:47 PM Rafia Sabih <rafia.pghackers@gmail.com> wrote:
>
> > It seems that in beentry->st_idle_time, you want to compute the
> > STATE_IDLE, but that state is not handled in the outer "if", that
> > means whenever it comes out of the
> > STATE_IDLE, it will not enter inside this if check. You can run and
> > test, I am sure that with this patch the "idle_time" will always
> > remain 0.
> >
> Thank you Dilip for your time on this.
> And yes you are right in both your observations.
> Please find the attached patch for the updated version.
Looks fine now except these variable names,
PgStat_Counter pgStatTransactionIdleTime = 0;
+PgStat_Counter pgStatTransactionIdleInTxnTime = 0;
Now, pgStatTransactionIdleTime is collecting just the Idle time so
pgStatTransactionIdleTime should be renamed to "pgStatIdleTime" and
pgStatTransactionIdleInTxnTime should be renamed to
"pgStatTransactionIdleTime"
--
Regards,
Dilip Kumar
EnterpriseDB: http://www.enterprisedb.com