On Tue, Nov 30, 2021 at 3:00 AM Peter Geoghegan <pg@bowt.ie> wrote:
>
> On Wed, Nov 24, 2021 at 4:48 AM Masahiko Sawada <sawada.mshk@gmail.com> wrote:
> > The patch renames dead tuples to dead items at some places and to
> > dead TIDs at some places.
>
> > I think it's more consistent if we change it to one side. I prefer "dead items".
>
> I just pushed a version of the patch that still uses both terms when
> talking about dead_items.
Thanks! I'll change my parallel vacuum refactoring patch accordingly.
Regarding the commit, I think that there still is one place in
lazyvacuum.c where we can change "dead tuples” to "dead items”:
/*
* Allocate the space for dead tuples. Note that this handles parallel
* VACUUM initialization as part of allocating shared memory space used
* for dead_items.
*/
dead_items_alloc(vacrel, params->nworkers);
dead_items = vacrel->dead_items;
Also, the commit doesn't change both PROGRESS_VACUUM_MAX_DEAD_TUPLES
and PROGRESS_VACUUM_NUM_DEAD_TUPLES. Did you leave them on purpose?
Regards,
--
Masahiko Sawada
EDB: https://www.enterprisedb.com/