Re: [PATCH] Function to get size of asynchronous notification queue - Mailing list pgsql-hackers

From Gurjeet Singh
Subject Re: [PATCH] Function to get size of asynchronous notification queue
Date
Msg-id CABwTF4Umt17GW3FZYQOHQEMPipE6=M4sV9Q5xn=BPofy8n3JyQ@mail.gmail.com
Whole thread Raw
In response to Re: [PATCH] Function to get size of asynchronous notification queue  (Brendan Jurd <direvus@gmail.com>)
Responses Re: [PATCH] Function to get size of asynchronous notification queue
List pgsql-hackers
On Thu, Jun 25, 2015 at 8:43 PM, Brendan Jurd <direvus@gmail.com> wrote:
On Fri, 26 Jun 2015 at 06:03 Gurjeet Singh <gurjeet@singh.im> wrote:


s/proportion/fraction/

I think of these as synonymous -- do you have any particular reason to prefer "fraction"?  I don't feel strongly about it either way, so I'm quite happy to go with fraction if folks find that more expressive.

It just feels better to me in this context.

If the number of times used in Postgres code is any measure, 'fraction' wins hands down: "proportion" : 33, "fraction": 620.

I don't feel strongly about it, either. I can leave it up to the committer to decide.
 
 

+ * The caller must hold (at least) shared AysncQueueLock.

A possibly better wording: The caller must hold AysncQueueLock in (at least) shared mode.

Yes, that is more accurate.

OK. 
 
 

Unnecessary whitespace changes in pg_proc.h for existing functions.


I did group the asynchronous notification functions together, which seemed reasonable as there are now three of them, and changed the tabbing between the function name and namespace ID to match, as is done elsewhere in pg_proc.h.  I think those changes improve readability, but again I don't feel strongly about it.

Fair enough.
 

+DESCR("get the current usage of the asynchronous notification queue");

A possibly better wording: get the fraction of the asynchronous notification queue currently in use

I have no objections to your wording.


OK. Please send a new patch with the changes you agree to, and I can mark it ready for committer.

Best regards,
--

pgsql-hackers by date:

Previous
From: David Christensen
Date:
Subject: [PATCH] Comment fix for miscinit.c
Next
From: David Rowley
Date:
Subject: Patch to fix spelling mistake in error message