On Thu, Jun 20, 2019 at 6:48 AM Amit Kapila <amit.kapila16@gmail.com> wrote:
> > for (;;)
> > {
> > UnpackedUndoRecord *uur = UndoFetchRecord(urp);
> > if (i like this one)
> > break;
> > urp = uur->uur_blkprev; // should be renamed, since zedstore +
> > probably others will have tuple chains not block chains
> ..
>
> +1 for renaming this variable. How about uur_prev_ver or uur_prevver
> or uur_verprev? Any other suggestions?
Maybe just uur_previous or uur_prevundo or something like that. We've
already got a uur_prevurp, but that's really pretty misnamed and IMHO
it doesn't belong in this structure anyway. (uur_next is also a bad
name and also doesn't belong in this structure.)
I don't think we want to use 'ver' because that supposes that undo is
being used to track tuple versions, which is a likely use but perhaps
not the only one.
--
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company