On Thu, Feb 08, 2024 at 11:59:54AM -0800, Andres Freund wrote: > On 2024-02-08 13:44:02 -0500, Tom Lane wrote: >> Are we okay with using macros that (a) have double evaluation hazards >> and (b) don't enforce the data types being compared are the same? >> I think static inlines might be a safer technology. > > +1
Agreed on static inlines.
Seems to be a general consensus on static inlines. I'll get a new patch.
> I'd put these static inlines into common/int.h. I don't think this is common > enough to warrant being in c.h. Probably also doesn't hurt to have a not quite > as generic name as INT_CMP, I'd not be too surprised if that's defined in some > library. > > > I think it's worth following int.h's pattern of including [s]igned/[u]nsigned > in the name, an efficient implementation for signed might not be the same as > for unsigned. And if we use static inlines, we need to do so for correct > semantics anyway.