>> I've come to value greppability of source code pretty highly. I think
> that
>> some of the points you raise are valid, but in my (minority) opinion
>> overloading creates more problems than it solves. You're not going to
>> convince me that get() is *ever* a good name for a function - you might as
>> well call it thing() or foo() for all the useful information that name
> conveys.
What about extract()? That's consistent with the function we already
use for timestamps and intervals, and is more clear than get().
On the other hand, to_string() seems like a GREAT name for an overloaded
function. You know that it takes some other type as an argument,
possibly several other types, and will always output a string.
--
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com