Thanks, naming conventions, and count() - Mailing list pgsql-hackers

From Casey Lyon
Subject Thanks, naming conventions, and count()
Date
Msg-id 3AECC6B3.6090008@earthcars.com
Whole thread Raw
Responses Re: Thanks, naming conventions, and count()  (Bruce Momjian <pgman@candle.pha.pa.us>)
List pgsql-hackers
First off I just wanted to give a big 'thank you' to all the developers and contributors
who have made PostgreSQL what it is today. I haven't come across a single thing
since my first experience with it a few years ago that hasn't been corrected, sped
up, or otherwise postively enhanced!

In working with 7.1 over the past couple weeks, I've noted the following mods may
add to usability and speed:

o v7.1 changed the database naming convention to be all numeric; I suggest having  the DB engine create symbolic links
whencreating a new DB and subsequent tables.  For instance, in creating a database 'foo' with table 'bar' the
/path/to/pgsql/data/base folder will have a new folder named something like '18720'; this folder could also  have a
symboliclink to 'foo'. Then in the '18720' folder rather than just having  numeric files for each table, pk, index,
etc.  there could be symbolic links following  the naming convention 'bar', 'pk_foo_pkey', 'field1_foo_ukey',
'field2_foo_key'.
  Maybe this would work best as configurable flag that could be set during compilation or  in the conf file.

o count() should use index scans for tables with a PK; scans would be on the PK index;  even after running 'vacuum
analyze'such a query still uses a sequential scan. For  instance, "select count(*) from bar" and even "select(pk_name)
frombar" both use  sequential scans. Likewise, scans on fields with indexes should use the index.
 


I hope this input is useful; keep up the excellent work,

Casey Lyon
Systems Engineer
Earthcars.com, Inc
www.earthcars.com
casey@earthcars.com



pgsql-hackers by date:

Previous
From: Bruce Momjian
Date:
Subject: Re: [PATCHES] Re: Support for %TYPE in CREATE FUNCTION
Next
From: Bruce Momjian
Date:
Subject: Re: Thanks, naming conventions, and count()