Re: Memo on dropping practices - Mailing list pgsql-hackers

From Tom Lane
Subject Re: Memo on dropping practices
Date
Msg-id 3840.1026579196@sss.pgh.pa.us
Whole thread Raw
In response to Re: Memo on dropping practices  (Bruce Momjian <pgman@candle.pha.pa.us>)
Responses Re: Memo on dropping practices  (Bruce Momjian <pgman@candle.pha.pa.us>)
List pgsql-hackers
Bruce Momjian <pgman@candle.pha.pa.us> writes:
>> The correct thing to do is to call performDeletion() with a parameter

> Should it be called performDrop rather than Deletion?

Well, if you want to rationalize the naming of these various routines:

I think DROP ought to be associated with the SQL-level commands.
performDeletion is the next level down (since it doesn't do any
permissions checks) and then there are the bottom-level deletion
routines for each object type (which do even less).  It would make sense
to choose different verbs for each level.  Right now, since I just split
RemoveFoo into two routines and called the second one RemoveFooById,
it's not very mnemonic at all.  Perhaps:
DropFoo        --- top level, corresponds to SQL DROP command
performSomething -- dependency controller
RemoveFoo    --- bottom level deleter

Not sure what "performSomething" should be called, but I'd like to
think of a verb that's not either Drop or Remove.  I'm not wedded to
Remove for the bottom level, either.  Thoughts?
        regards, tom lane


pgsql-hackers by date:

Previous
From: Bruce Momjian
Date:
Subject: Re: Unique and Primary Key Constraints
Next
From: Tom Lane
Date:
Subject: Re: Unique and Primary Key Constraints