Michael Paquier <michael@paquier.xyz> writes:
> Looked at it already. And yes, I can see the difference. This comes
> from the switch from cancel_pressed to CancelRequested in psql,
> especially PSQLexecWatch() in this case. And actually, now that I
> look at it, I think that we should simply get rid of cancel_pressed in
> psql completely and replace it with CancelRequested. This also
> removes the need of having cancel_pressed defined in print.c, which
> was not really wanted originally. Attached is a patch which addresses
> the issue for me, and cleans up the code while on it. Fabien, Jeff,
> can you confirm please?
Given the rather small number of existing uses of CancelRequested,
I wonder if it wouldn't be a better idea to rename it to cancel_pressed?
Also, perhaps I am missing something, but I do not see anyplace in the
current code base that ever *clears* CancelRequested. How much has
this code been tested? Is it really sane to remove the setting of that
flag from psql_cancel_callback, as this patch does? Is it sane that
CancelRequested isn't declared volatile?
regards, tom lane