Heikki Linnakangas <hlinnaka@iki.fi> writes:
> ReorderBufferGetRelids allocates an array with MemoryContextAlloc, and
> ReorderBufferReturnRelids just calls pfree. The pools are long gone, and
> now the naming looks weird.
> Attached patch renames those functions and other such functions to use
> the terms Alloc/Free. I actually wonder if we should go further and
> remove these functions altogether, and change the callers to call
> MemoryContextAlloc directly. But I didn't do that yet.
Yeah, that is very confusing, especially since nearby code uses
names like ReorderBufferGetFoo for functions that are lookups not
allocations. +1 for Alloc/Free where that's an accurate description.
Given that a lot of these are not just one-liners, I'm not sure that
getting rid of the ones that are would help much.
regards, tom lane