Hello,
Gregory Stark <stark@enterprisedb.com> wrote:
> Here's an update to eliminate two small bitrot conflicts.
I read your patch with interest, but found some trivial bad manners.
* LET_OS_MANAGE_FILESIZE is already obsoleted.
You don't have to cope with the option.
* Type mismatch in prefetch_pages
A variable prefetch_pages is defined as "unsigned" or "int"
in some places. Why don't you define it only once in a header
and include the header in source files?
* Assignment to prefetch_pages
What do "+0.99" means here? [assign_io_concurrency()] + prefetch_pages = new_prefetch_pages+0.99;
You want to do as follows, right? + prefetch_pages = (int) ceil(new_prefetch_pages);
Regards,
---
ITAGAKI Takahiro
NTT Open Source Software Center