> Bruce Momjian - CVS <momjian@hub.org> writes:
> > Rename ParseFuncOrColumn() to ParseColumnOrFunc().
>
> This is an improvement?
>
> Considering that the function is primarily concerned with parsing
> function calls, I'd call this a net decrease in intelligibility.
Here is my comment added to the top of the code. Is it correct?
/*
* parse function
* This code is confusing code because the database can accept
* relation.column, column.function, or relation.column.function.
* It can also be called as func(col) or func(col,col).
*
* Funcname is the first parameter, and fargs are the rest.
*/
ParseColumnOrFunc(ParseState *pstate, char *funcname, List *fargs,
bool agg_star, bool agg_distinct,
int precedence)
--
Bruce Momjian | http://candle.pha.pa.us
pgman@candle.pha.pa.us | (610) 853-3000
+ If your life is a hard drive, | 830 Blythe Avenue
+ Christ can be your backup. | Drexel Hill, Pennsylvania 19026