Tomas Vondra <tv@fuzzy.cz> writes:
> One thing I'm wondering about is that the InstrumentOptions are not
> exclusive - INSTRUMENT_TIMER means 'collect timing and row counts' while
> INSTRUMENT_ROWS means 'collect row counts'. Wouldn't it be better to
> redefine the INSTRUMENT_TIMER so that it collects just timing info. I.e.
> to get the current behaviour, you'd have to do this
> instrument_options |= (INSTRUMENT_TIMER | INSTRUMENT_ROWS)
> It's quite trivial change in explain.c, the problem I have with that is
> that it might break extensions.
I'm not especially concerned by that angle --- we make bigger API
changes all the time. But you could change the name, eg
instrument_options |= (INSTRUMENT_TIMING | INSTRUMENT_ROWS)
and then #define INSTRUMENT_TIMER as the OR of the two real bits
for backward compatibility.
regards, tom lane