On Sat, 2007-05-05 at 22:49 -0500, Michael Glaesemann wrote:
> Would it make more sense to have phrase it in the positive sense?
> i.e., --enable-floating-point-datetimes? I guess that's a bit longer,
> but it says what you're doing, rather than what you're *not* doing.
I think the primary reason people will want to use FP-based datetimes is
because they can't use integer-based datetimes for compatibility reasons
(e.g. no OS support for 64-bit integers, or they need to remain
compatible with old applications). The situation is analogous to
--without-spinlocks: we could call that --enable-slow-locking or
something, but that would sound like we're enabling an additional
feature.
It would also mean there would be an implicit relationship between
"--enable-integer-datetimes" and "--enable-fp-datetimes" (at most one
can be true). IMHO it would be simpler to just keep a single boolean
variable ("integer datetimes enabled or not").
-Neil