Re: Review: listagg aggregate - Mailing list pgsql-hackers

From Takahiro Itagaki
Subject Re: Review: listagg aggregate
Date
Msg-id 20100128114706.987A.52131E4D@oss.ntt.co.jp
Whole thread Raw
In response to Re: Review: listagg aggregate  (Pavel Stehule <pavel.stehule@gmail.com>)
Responses Re: Review: listagg aggregate  ("David E. Wheeler" <david@kineticode.com>)
Re: Review: listagg aggregate  (Pavel Stehule <pavel.stehule@gmail.com>)
Re: Review: listagg aggregate  (Robert Haas <robertmhaas@gmail.com>)
List pgsql-hackers
Pavel Stehule <pavel.stehule@gmail.com> wrote:

> with actualised oids

I'm checking the patch for commit, and have a couple of comments.

* I think we cannot cache the delimiter at the first call.
  For example,
    SELECT string_agg(elem, delim)
      FROM (VALUES('A', ','), ('B', '+'), ('C', '*')) t(elem, delim);
  should return 'A+B*C' rather than 'A,B,C'.

* Can we use StringInfo directly as the aggregate context instead of
  StringAggState? For the first reason, we need to drop 'delimiter' field
  from struct StringAggState. Now it has only StringInfo field.

* We'd better avoiding to call text_to_cstring() for delimitors and elements
  for performance reason. We can use appendBinaryStringInfo() here.

My proposal patch attached.

Also, I've not changed it yet, but it might be considerable:

* Do we need better names for string_agg1_transfn and string_agg2_transfn?
  They are almost "internal names", but we could have more
  like string_agg_with_sep_transfn.

Comments?

Regards,
---
Takahiro Itagaki
NTT Open Source Software Center


Attachment

pgsql-hackers by date:

Previous
From: Andrew Dunstan
Date:
Subject: Re: make everything target
Next
From: "David E. Wheeler"
Date:
Subject: Re: Review: listagg aggregate