Re: [DOCS] Aggregate expression syntax - Mailing list pgsql-docs

From David G Johnston
Subject Re: [DOCS] Aggregate expression syntax
Date
Msg-id 1421775890421-5834768.post@n5.nabble.com
Whole thread Raw
In response to Re: Aggregate expression syntax  (Tom Lane <tgl@sss.pgh.pa.us>)
List pgsql-docs
Tom Lane-2 wrote
> Thom Brown <

> thom@

> > writes:
>> Looking at the syntax for aggregate expressions in the docs, it seems the
>> first three forms could perhaps be merged since the ALL and DISTINCT
>> keywords are effectively optional.
>
> Dunno, just seems harder to read to me...

I'm generally for making the syntax part more succinct and addressing
learning concerns with examples.  The extra noise that needs to be filtered
out when trying to figure out why different structures exist makes it
difficult to read too.

That said, having at least a bare-minimum expression would be helpful:

aggregate_name ( expression )

And now decide whether to have a combined syntax block or keep building
things up like:

aggregate_name ( [ ALL | DISTINCT ] expression [ , ... ] [ order_by_clause]
)
aggregate_name ( argument_clause ) [ FILTER ( WHERE [ filter_clause ] ) ]

argument_clause := " [ ALL | DISTINCT ] expression [ , ... ] [
order_by_clause ] "

If we are going to repeat long and complex parts of the syntax naming them
will make reading subsequent syntax expressions easier and provide semantic
meaning to the reader.  The existing forms, while correct, are repetitive
and that is what is being targeted but combining them into a single syntax
block.  But if that is too hard to read and understand then maybe some other
means of simplification, like my example above, would work better.

David J.







--
View this message in context: http://postgresql.nabble.com/Aggregate-expression-syntax-tp5834726p5834768.html
Sent from the PostgreSQL - docs mailing list archive at Nabble.com.


--
Sent via pgsql-docs mailing list (pgsql-docs@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-docs


pgsql-docs by date:

Previous
From: Tom Lane
Date:
Subject: Re: [DOCS] Aggregate expression syntax
Next
From: J Connolly
Date:
Subject: how do I suggest a small docs change?