Re: Do I need to rebuild php-pgsql for 8.2.3

From: Adam Rich
Subject: Re: Do I need to rebuild php-pgsql for 8.2.3
Date: ,
Msg-id: 070f01c77c62$561c1a30$6400a8c0@dualcore
(view: Whole thread, Raw)
In response to: Re: Do I need to rebuild php-pgsql for 8.2.3  ("Michael Dengler")
Responses: Re: Do I need to rebuild php-pgsql for 8.2.3  ("Michael Dengler")
List: pgsql-performance

Tree view

Do I need to rebuild php-pgsql for 8.2.3  ("Michael Dengler", )
 Re: Do I need to rebuild php-pgsql for 8.2.3  ("Guillaume Smet", )
  Re: Do I need to rebuild php-pgsql for 8.2.3  (Devrim GÜNDÜZ, )
   Re: Do I need to rebuild php-pgsql for 8.2.3  ("Michael Dengler", )
    Re: Do I need to rebuild php-pgsql for 8.2.3  ("Adam Rich", )
     Re: Do I need to rebuild php-pgsql for 8.2.3  ("Michael Dengler", )
    Re: Do I need to rebuild php-pgsql for 8.2.3  (Devrim GÜNDÜZ, )

Here's what I do...
 
1) Install postgresql-libs from the RHEL source
2) Install compat-postgresql-libs from postgresql.org (install, not upgrade, use rpm -hiv) use force if necessary
3) Install postgresq-libs from postgresql.org (again, install, not upgrade, use rpm-hiv) use force if necessary
 
If done correctly, you'll end up with all 3 client versions:
 
/usr/lib/libpq.so.3
/usr/lib/libpq.so.4
/usr/lib/libpq.so.5
 
 
-----Original Message-----
From: [mailto:] On Behalf Of Michael Dengler
Sent: Wednesday, April 11, 2007 12:25 PM
To: Devrim GÜNDÜZ
Cc: pgsql-performance; Guillaume Smet
Subject: Re: [PERFORM] Do I need to rebuild php-pgsql for 8.2.3

Hi,

Thanks for the info. One more thing....I am in rpm hell. When I try to
# rpm -Uvh postgresql-libs-8.2.3-1PGDG.i686.rpm
I get:
error: Failed dependencies:
        libpq.so.3 is needed by (installed) perl-DBD-Pg-1.31-6.i386
        libpq.so.3 is needed by (installed) postgresql-python-7.4.13-2.RHEL4.1.i386
        libpq.so.3 is needed by (installed) php-pgsql-4.3.9-3.15.i386
and when I try:
# rpm -ivh compat-postgresql-libs-3-3PGDG.i686.rpm
I get:
error: Failed dependencies:
        postgresql-libs < 8.0.2 conflicts with compat-postgresql-libs-3-3PGDG.i686
grrrrr...
should just force the upgrade (ie. --nodeps)?

Thanks

Mike


On 4/10/07, Devrim GÜNDÜZ <> wrote:
Hi,

On Tue, 2007-04-10 at 22:55 +0200, Guillaume Smet wrote:
> See http://developer.postgresql.org/~devrim/rpms/compat/ and choose
> the correct package for your architecture.

... or better, each RHEL4 directory in our FTP site has compat package
(that directory is not up2date now).

Regards,
--
Devrim GÜNDÜZ
PostgreSQL Replication, Consulting, Custom Development, 24x7 support
Managed Services, Shared and Dedicated Hosting
Co-Authors: plPHP, ODBCng - http://www.commandprompt.com/





pgsql-performance by date:

From: "Michael Dengler"
Date:
Subject: Re: Do I need to rebuild php-pgsql for 8.2.3
From: "Jan de Visser"
Date:
Subject: Re: Beginner Question