On Wed, Dec 01, 2021 at 09:34:39PM -0600, Justin Pryzby wrote:
>> @@ -2762,7 +2763,8 @@ static struct config_int ConfigureNamesInt[] =
>> {"pre_auth_delay", PGC_SIGHUP, DEVELOPER_OPTIONS,
>> - gettext_noop("Waits N seconds on connection startup before authentication."),
>> + gettext_noop("Sets the amount of time to wait on connection "
>> + "startup before authentication."),
>> gettext_noop("This allows attaching a debugger to the process."),
>
> I wonder if these should say "Sets the amount of time to wait [before]
> authentication during connection startup"
Hmm. I don't see much a difference between both of wordings in this
context.
>> gettext_noop("Write a message to the server log if checkpoints "
>> - "caused by the filling of checkpoint segment files happens more "
>> + "caused by the filling of WAL segment files happen more "
>> "frequently than this number of seconds. Zero turns off the warning."),
>
> Should this still say "seconds" ?
> Or change it to "this amount of time"?
> I'm not sure.
Either way would be fine by me, though I'd agree to be consistent and
use "this amount of time" here.
>> {"log_rotation_size", PGC_SIGHUP, LOGGING_WHERE,
>> - gettext_noop("Automatic log file rotation will occur after N kilobytes."),
>> + gettext_noop("Sets the maximum size of log file to reach before "
>> + "forcing log file rotation."),
>
> Actually, I think that for log_rotation_size, it should not say "forcing".
>
> "Sets the maximum size a log file can reach before being rotated"
Okay. Fine by me.
> BTW the EXPLAIN flag for enable_incremental_sort could be backpatched to v13.
This could cause small diffs in EXPLAIN outputs, which could be
surprising. This is not worth taking any risks.
--
Michael