pgsql: Fail REPACK in presence of invalid indexes, take 2 - Mailing list pgsql-committers

From Álvaro Herrera
Subject pgsql: Fail REPACK in presence of invalid indexes, take 2
Date
Msg-id E1x6Uwj-00000000SXv-2hGY@gemulon.postgresql.org
Whole thread
Responses Re: pgsql: Fail REPACK in presence of invalid indexes, take 2
List pgsql-committers
Fail REPACK in presence of invalid indexes, take 2

Commit 0c5d6269614e was confused about which indexes are potentially
problematic to rebuild: we thought only !indisready indexes could fail
to rebuild, and thus would attempt to rebuild !indisvalid ones that are
"ready" (that is, being maintained by DML but not yet completed).
However, that's wrong, because it could be that the validation phase of
such an index failed or was interrupted partway through.  So, have
REPACK throw an error with all !indisvalid indexes, not just those
!indisready.

(!indisready implies !indisvalid, so this is an expansion of what
happened with the previous commit.)

Reported-by: shihao zhong <zhong950419@gmail.com>
Backpatch-through: 19
Discussion: https://postgr.es/m/CAGRkXqRA4YetT8Nu3+1-45+ffTwi2bd1d1eDFME39Y9OPRMytQ@mail.gmail.com

Branch
------
REL_19_STABLE

Details
-------
https://git.postgresql.org/pg/commitdiff/0cabab44f12f4169e52a0ba61d810dd2801cd517

Modified Files
--------------
doc/src/sgml/ref/repack.sgml  |  6 ++++++
src/backend/commands/repack.c | 15 ++++++++-------
2 files changed, 14 insertions(+), 7 deletions(-)


pgsql-committers by date:

Previous
From: Peter Geoghegan
Date:
Subject: pgsql: Add slot-based table AM index scan interface.
Next
From: Peter Geoghegan
Date:
Subject: Re: pgsql: Fail REPACK in presence of invalid indexes, take 2