Rename TRY_POPCNT_FAST to TRY_POPCNT_X86_64.
This macro protects x86_64-specific code, and a subsequent commit
will introduce AArch64-specific versions of that code. To prevent
confusion, let's rename it to clearly indicate that it's for
x86_64. We should likely move this code to its own file (perhaps
merging it with the AVX-512 popcount code), but that is left as a
future exercise.
Reviewed-by: "Chiranmoy.Bhattacharya@fujitsu.com" <Chiranmoy.Bhattacharya@fujitsu.com>
Reviewed-by: John Naylor <johncnaylorls@gmail.com>
Discussion: https://postgr.es/m/010101936e4aaa70-b474ab9e-b9ce-474d-a3ba-a3dc223d295c-000000%40us-west-2.amazonses.com
Branch
------
master
Details
-------
https://git.postgresql.org/pg/commitdiff/9ac6f7e7ceb6e7c9b168bbf02bbe4662782dfa6e
Modified Files
--------------
src/include/port/pg_bitutils.h | 6 +++---
src/port/pg_bitutils.c | 14 +++++++-------
src/port/pg_popcount_avx512.c | 8 ++++----
3 files changed, 14 insertions(+), 14 deletions(-)