pgsql: Rename lo_create(oid, bytea) to lo_from_bytea(). - Mailing list pgsql-committers

From Tom Lane
Subject pgsql: Rename lo_create(oid, bytea) to lo_from_bytea().
Date
Msg-id E1WvAqL-00054W-0E@gemulon.postgresql.org
Whole thread Raw
List pgsql-committers
Rename lo_create(oid, bytea) to lo_from_bytea().

The previous naming broke the query that libpq's lo_initialize() uses
to collect the OIDs of the server-side functions it requires, because
that query effectively assumes that there is only one function named
lo_create in the pg_catalog schema (and likewise only one lo_open, etc).

While we should certainly make libpq more robust about this, the naive
query will remain in use in the field for the foreseeable future, so it
seems the only workable choice is to use a different name for the new
function.  lo_from_bytea() won a small straw poll.

Back-patch into 9.4 where the new function was introduced.

Branch
------
master

Details
-------
http://git.postgresql.org/pg/commitdiff/154146d208de7518bb6c8131dc8d2361f7f36f56

Modified Files
--------------
doc/src/sgml/lobj.sgml                       |    6 +++---
src/backend/libpq/be-fsstubs.c               |    4 ++--
src/include/catalog/catversion.h             |    2 +-
src/include/catalog/pg_proc.h                |    4 ++--
src/include/libpq/be-fsstubs.h               |    2 +-
src/test/regress/input/largeobject.source    |    2 +-
src/test/regress/output/largeobject.source   |    2 +-
src/test/regress/output/largeobject_1.source |    2 +-
8 files changed, 12 insertions(+), 12 deletions(-)


pgsql-committers by date:

Previous
From: Alvaro Herrera
Date:
Subject: pgsql: Fix typos
Next
From: Tom Lane
Date:
Subject: pgsql: Rename lo_create(oid, bytea) to lo_from_bytea().