Isn't it better with "autovacuum worker...." instead of "worker took too long to start; canceled" specific to "auto - Mailing list pgsql-hackers

From Bharath Rupireddy
Subject Isn't it better with "autovacuum worker...." instead of "worker took too long to start; canceled" specific to "auto
Date
Msg-id CALj2ACX2UHp76dqdoZq92a7v4APFuV5wJQ+AUrb+2HURrKN=NQ@mail.gmail.com
Whole thread Raw
Responses Re: Isn't it better with "autovacuum worker...." instead of "worker took too long to start; canceled" specific to "auto  ("Bossart, Nathan" <bossartn@amazon.com>)
List pgsql-hackers
Hi,

Is there a specific reason that we have a generic WARNING "worker took
too long to start; canceled" for an autovacuum worker? Isn't it better
with "autovacuum worker took too long to start; canceled"? It is
confusing to see the generic message in the server logs while
debugging an issue for a user who doesn't know the internals of
autovacuum code.

To be more informative about the message, how about the following:
1) ereport(WARNING,
                    (errmsg( "worker took too long to start"),
                     errdetail("Previous attempt to start autovacuum
worker was failed, canceled.")));
or
2) ereport(WARNING,
                    (errmsg( "worker took too long to start, canceled"),
                     errdetail("The postmaster couldn't start an
autovacuum worker.")));
or
3) ereport(WARNING,
                    (errmsg( "worker took too long to start, canceled"),
                     errdetail("Previous attempt to start autovacuum
worker was failed.")));
or
4) elog(WARNING, "postmaster couldn't start an autovacuum worker");

Thoughts?

Regards,
Bharath Rupireddy.



pgsql-hackers by date:

Previous
From: Jacob Champion
Date:
Subject: Re: allowing "map" for password auth methods with clientcert=verify-full
Next
From: Joshua Brindle
Date:
Subject: [PATCH] remove is_member_of_role() from header, add can_set_role()