Re: PostgreSQL Service Unable to Start After Archive Log delete - Mailing list pgsql-general

From Justin
Subject Re: PostgreSQL Service Unable to Start After Archive Log delete
Date
Msg-id CALL-XeOaR9zOoM4cFmVpsuF6M-QSPR3OwxxwZs+Mw_-agNFL4w@mail.gmail.com
Whole thread
List pgsql-general


On Thu, Sep 10, 2026 at 11:02 AM Oli Sennhauser <oli.sennhauser@fromdual.com> wrote:

Hi Loganathan


I am a complete PostgreSQL noob! Reading the manual (after googling) I found this: https://www.postgresql.org/docs/current/app-pgresetwal.html

When I tried to simulate your situation I ended up with this:




Loganathan, and Oli.
Yes you can use pg_resetwal to get PG to start to get more records that would be lost otherwise. 

CAN NOT STRESS THIS ENOUGH  using pg_resetwal is the last ditch option after exploring all other options. Use this to fetch what data can be fetched. DO NOT USE a database that has used pg_resetwal for any other activity other than getting missing records.

make a backup of the database before executing pg_walreset.   There are other options to get the data out of the PostgreSQL tables  but the catalog has to be intact.  pg_class, pg_attribute, pg_type.  loose those tables  the database is toast 

Would like to see the DR and backup methods that was being used. If normal housekeeping included purging WAL directories  there is a very big disconnect between the sysadmins and dbas

Best of luck

pgsql-general by date:

Previous
From: Igor Korot
Date:
Subject: Re: Optimizing query
Next
From: Alban Hertroys
Date:
Subject: Re: Upgrading 6 versions between 2 systems