I came across the following help message added in commit 1a759c83278:
+ HELP0(" WATCH_INTERVAL\n" + " number of seconds \\watch by default waits between executing the query buffer\n");
It took me a little while to understand it.
I'm on board with tweaking this.
How about the attached? We already have "(default: X)" in other places so this
aligns it better while simplifying the language.
This change is technically wrong on two points:
I pondered mentioning the 2s interval but the environment variable itself doesn't have a default, it's either set or unset which determines whether it provides the default or not. IMO, adding this detail produces too much text for little benefit.
Your wording loses the idea that this environment variable only establishes a new default that can be subsequently overridden by explicitly specifying an interval to \watch.