On Wed, Sep 16, 2026 at 8:08 PM Daniel Gustafsson <daniel@yesql.se> wrote:
> Ugh, I thought I had tested everything but clearly missed this one. Will fix immediately when back from lunch.
Here are another comments:
data_checksum_version field in xl_checkpoint_redo struct should be removed?
Otherwise, it seems to be included in WAL records unnecessarily even though
it is no longer used. No?
- database (or on a shared object), or NULL if data checksums are
- disabled.
- </para></entry>
+ database (or on a shared object). Detected failures are not reset if
+ the <xref linkend="guc-data-checksums"/> setting changes. Clusters
+ which are initialized without data checksums will show this as
+ <literal>0</literal>. In <productname>PostgreSQL</productname> version
+ 18 and earlier, this was set to <literal>NULL</literal> for clusters
+ with data checksums disabled.
+ </para>
+ </entry>
...
- this database (or on a shared object), or NULL if data checksums are
- disabled.
+ this database (or on a shared object). Last failure is reported
+ regardless of the <xref linkend="guc-data-checksums"/> setting.
These updates to monitoring.sgml from commit f19c0eccae9 also should be
reverted? checksum_failures and checksum_last_failure seem to return
NULL again when data checksums are disabled, so their descriptions would
otherwise be incorrect.
checksum_enable_offline() and checksum_disable_offline() in
Cluster.pm also seem to be unused now. Should they be removed as well?
Regards,
--
Fujii Masao