Yurii Rashkovskii <yrashk@omnigres.com> writes: >> Can you propose a specific change to clean it up? I wanted to write >> just "PG_MODULE_MAGIC_DATA()", but I'm not sure that's valid C either.
> I was thinking about passing `.name = NULL, .version = NULL` instead of > `0`—do you have any reservations about this?
If we're going that way, I'd minimize it to just ".name = NULL".